About TEAM Mentor

Accessing and Reading Content

Installation

Administration

Editing Content

Eclipse for Fortify plugin

HP Fortify SCA UI Integration

Using the Jade Fail Safe Version

Minimum Requirements

Minimum Server Requirements

The following hardware and software is required to run TEAM Mentor.

Server Side Requirements

  • Windows 2012 R2 (64 Bit) with IIS 8.0 or higher
  • NET Framework 4.5.1 ( You can download this version from http://www.microsoft.com/en-us/download/details.aspx?id=40779 )
  • 7-Zip ( Available at http://www.7-zip.org )
  • Git Version Control with Tools ( Available at http://www.git-scm.com/download/win )
  • NodeJS ( Distributed with TEAM Mentor ZIP File )
  • IIS AAR 3.0 Extension ( Distributed with TEAM Mentor ZIP File )
  • IIS URLRewrite2 Extension ( Distributed with TEAM Mentor ZIP File )
  • 4GB of RAM
  • 4GB of Storage
  • 2 URLs. resolvable through DNS. One for administration the other for user access
  • 2 SSL Certificates. One for each URL. Can be one wildcard or Subject Alternative Names certificate as well.

Please note that you will need 7-Zip application to unzip the TEAM Mentor package.

Please note that it may be possible to run TEAM Mentor with less RAM and Storage. However performance does degrade under load and minimal configuration listed above is recommended for production environments. Also note, when connecting to TEAM Mentor on local machine (connecting to "localhost") SSL certificate is not required. Self-signed certificate may be used for test environments, with administration only available locally.

Client Side Requirements

Following browsers and platforms are supported:

The full version of TEAM Mentor 4.0, code named Flare, supports:

  • IE 11
  • Firefox 42 and above
  • Chrome 46 and above
  • Safari 9 and above (on OSX only)
  • Experimental support for iOS and Android mobile browsers

The fail safe TEAM Mentor 4.0, code named Jade, supports all browsers including IE8 and Lynx.
Mobile browsers for Android and iOS are also supported.

TM 3.6 Back-end (used for Administration and Editing) supports the following browsers:

  • IE 11
  • Firefox 42 and above
  • Chrome 46 and above
  • Safari 9 and above (on OSX only)